const regex = new RegExp('\\w*?(p).*([a])[^l]*(l)[a-zA-Z\\d]*?(a)({)\\w*?(o).+([W-w])(h)[^f]+(f).*', 'g')
const str = `LZckWnfFS0NyHyjMpObY0aLi:cVJVcVZkWnfFS0NvlQNiyZa{NVCHJ6zWPPI5KXxGZyUo55ywhR8LzVm4KM92kSfi}fzQHpjMpOb0ii?`;
const subst = `\9\3\2g\5t\7\6ste\1s\4\8e\2d}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);