const regex = /[\d]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d]', 'gm')
const str = `I W4nt 2 Br3ak Fr33`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);