use strict;
my $str = 'I W4nt 2 Br3ak Fr33';
my $regex = qr/[\d]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";