#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=(\d)..\1(?!0*$)|(?:0..1|1..2|2..3|3..4|4..5|5..6|6..7|7..8|8..9|9..0)0*$)\d){3}\d{3}$"
Local $sString = "Pass:" & @CRLF & _
"000001" & @CRLF & _
"009010" & @CRLF & _
"010011" & @CRLF & _
"019020" & @CRLF & _
"057058" & @CRLF & _
"099100" & @CRLF & _
"100101" & @CRLF & _
"299300" & @CRLF & _
"398399" & @CRLF & _
"404405" & @CRLF & _
"500501" & @CRLF & _
"665666" & @CRLF & _
"666667" & @CRLF & _
"899900" & @CRLF & _
"998999" & @CRLF & _
"" & @CRLF & _
"Edge Case:" & @CRLF & _
"999000" & @CRLF & _
"" & @CRLF & _
"Not Pass:" & @CRLF & _
"000000" & @CRLF & _
"123456" & @CRLF & _
"123234" & @CRLF & _
"000002" & @CRLF & _
"010002" & @CRLF & _
"010012" & @CRLF & _
"050060" & @CRLF & _
"397399" & @CRLF & _
"0071072" & @CRLF & _
"89090" & @CRLF & _
"0890900" & @CRLF & _
"1234" & @CRLF & _
"200210" & @CRLF & _
"123123124"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")