use strict;
my $str = 'Pass:
000001
009010
010011
019020
057058
099100
100101
299300
398399
404405
500501
665666
666667
899900
998999
Edge Case:
999000
Not Pass:
000000
123456
123234
000002
010002
010012
050060
397399
0071072
89090
0890900
1234
200210
123123124';
my $regex = qr/^(?:(?=(\d)..\1(?!0*$)|(?:0..1|1..2|2..3|3..4|4..5|5..6|6..7|7..8|8..9|9..0)0*$)\d){3}\d{3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}