using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?=(\d)..\1(?!0*$)|(?:0..1|1..2|2..3|3..4|4..5|5..6|6..7|7..8|8..9|9..0)0*$)\d){3}\d{3}$";
string input = @"Pass:
000001
009010
010011
019020
057058
099100
100101
299300
398399
404405
500501
665666
666667
899900
998999
Edge Case:
999000
Not Pass:
000000
123456
123234
000002
010002
010012
050060
397399
0071072
89090
0890900
1234
200210
123123124";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}