using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""SystemID"":\s*""[A-Z0-9]+"")";
string input = @"{
""EmployeeData"": [
{
""SystemID"": ""U6JDD""
},
{
""SystemID"": ""
},
{
""SystemID"": null
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}