package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("SystemID":\s*"[A-Z0-9]+")`)
var str = `{
"EmployeeData": [
{
"SystemID": "U6JDD"
},
{
"SystemID": ""
},
{
"SystemID": null
}
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}