re = /("SystemID":\s*"[A-Z0-9]+")/m
str = '{
"EmployeeData": [
{
"SystemID": "U6JDD"
},
{
"SystemID": ""
},
{
"SystemID": null
}
]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end