const regex = /\.0*$|(\.\d*[1-9])0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.0*$|(\\.\\d*[1-9])0+$', 'gm')
const str = `0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);