re = /\.0*$|(\.\d*[1-9])0+$/m
str = '0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result