$re = '/\.0*$|(\.\d*[1-9])0+$/m';
$str = '0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;