// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.0*$|(\.\d*[1-9])0+$").unwrap();
let string = "0
0.0
0.00
1.0
10.00
100
200.010
200.01023000
200.100
200.1002";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}