using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\p{L}]+(?:\s[\p{L}]+)*$";
string input = @"GEÇERLİ
ÖMER
ENES SEFA
ENES SEFA KÜCCÜK
ŞEYDA
İÇçiöşŞğĞ
GEÇERSİZ
1enes se
.dsds
enes dsdsd
öçds12
dd2sds";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}