package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{L}]+(?:\s[\p{L}]+)*$`)
var str = `GEÇERLİ
ÖMER
ENES SEFA
ENES SEFA KÜCCÜK
ŞEYDA
İÇçiöşŞğĞ
GEÇERSİZ
1enes se
.dsds
enes dsdsd
öçds12
dd2sds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}