import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{L}]+(?:\\s[\\p{L}]+)*$";
final String string = "GEÇERLİ\n"
+ "ÖMER\n"
+ "ENES SEFA\n"
+ "ENES SEFA KÜCCÜK\n"
+ "ŞEYDA\n"
+ "İÇçiöşŞğĞ\n\n"
+ "GEÇERSİZ\n"
+ "1enes se\n"
+ ".dsds \n"
+ "enes dsdsd\n"
+ "öçds12\n"
+ "dd2sds";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}