#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$"
Local $sString = "# linuxserver/prowlarr:1.16.2.4435-ls67" & @CRLF & _
"1.16.2.4435-ls67" & @CRLF & _
"" & @CRLF & _
"# linuxserver/radarr:5.4.6.8723-ls215" & @CRLF & _
"5.4.6.8723-ls215" & @CRLF & _
"" & @CRLF & _
"# linuxserver/sonarr:4.0.4.1491-ls236" & @CRLF & _
"4.0.4.1491-ls236" & @CRLF & _
"" & @CRLF & _
"# linuxserver/transmission:4.0.5-r1-ls233" & @CRLF & _
"4.0.5-r1-ls233"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")