use strict;
my $str = '# linuxserver/prowlarr:1.16.2.4435-ls67
1.16.2.4435-ls67
# linuxserver/radarr:5.4.6.8723-ls215
5.4.6.8723-ls215
# linuxserver/sonarr:4.0.4.1491-ls236
4.0.4.1491-ls236
# linuxserver/transmission:4.0.5-r1-ls233
4.0.5-r1-ls233';
my $regex = qr/^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}