# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$"
test_str = ("# linuxserver/prowlarr:1.16.2.4435-ls67\n"
"1.16.2.4435-ls67\n\n"
"# linuxserver/radarr:5.4.6.8723-ls215\n"
"5.4.6.8723-ls215\n\n"
"# linuxserver/sonarr:4.0.4.1491-ls236\n"
"4.0.4.1491-ls236\n\n"
"# linuxserver/transmission:4.0.5-r1-ls233\n"
"4.0.5-r1-ls233")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.