using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?<compatibility>(amd64|arm64v8|arm32v7)?)-)?(?<major>v?\d+)\.(?<minor>\d+)\.(?<patch>\d+)([\.\-](r|ls)?(?<build>\d+))(-ls(?<revision>\d+))?$";
string input = @"# linuxserver/prowlarr:1.16.2.4435-ls67
1.16.2.4435-ls67
# linuxserver/radarr:5.4.6.8723-ls215
5.4.6.8723-ls215
# linuxserver/sonarr:4.0.4.1491-ls236
4.0.4.1491-ls236
# linuxserver/transmission:4.0.5-r1-ls233
4.0.5-r1-ls233";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}