#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:([a-zA-Z0-9]+)=(?:([^\v '"]+)|"(.*?)"|'(.*?)')|([a-zA-Z0-9]+))"
Local $sString = "a=123 344=555" & @CRLF & _
"a=1 b=2 c=3" & @CRLF & _
"delim=; trst=.... c=3" & @CRLF & _
"delim=; trst=".... " c=3" & @CRLF & _
"x=12 abc="asdasda"" & @CRLF & _
"x12 abc="asdasda"" & @CRLF & _
"x13 xddss='asdasda'" & @CRLF & _
"x13=213 xddss='asdasda'" & @CRLF & _
"adas=123 123=312312 x="dasdas asd as as das das das das das" as="adsasdas"" & @CRLF & _
"adas=123 123=312312 x="dasdas asd as as = das das das das das" as="adsasdas"" & @CRLF & _
"adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'" & @CRLF & _
"adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")