# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:([a-zA-Z0-9]+)=(?:([^\v '\"]+)|\"(.*?)\"|'(.*?)')|([a-zA-Z0-9]+))"
test_str = ("a=123 344=555\n"
"a=1 b=2 c=3\n"
"delim=; trst=.... c=3\n"
"delim=; trst=\".... \" c=3\n"
"x=12 abc=\"asdasda\"\n"
"x12 abc=\"asdasda\"\n"
"x13 xddss='asdasda'\n"
"x13=213 xddss='asdasda'\n"
"adas=123 123=312312 x=\"dasdas asd as as das das das das das\" as=\"adsasdas\"\n"
"adas=123 123=312312 x=\"dasdas asd as as = das das das das das\" as=\"adsasdas\"\n"
"adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'\n"
"adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.