const regex = /(?:([a-zA-Z0-9]+)=(?:([^\v '"]+)|"(.*?)"|'(.*?)')|([a-zA-Z0-9]+))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:([a-zA-Z0-9]+)=(?:([^\\v \'"]+)|"(.*?)"|\'(.*?)\')|([a-zA-Z0-9]+))', 'gs')
const str = `a=123 344=555
a=1 b=2 c=3
delim=; trst=.... c=3
delim=; trst=".... " c=3
x=12 abc="asdasda"
x12 abc="asdasda"
x13 xddss='asdasda'
x13=213 xddss='asdasda'
adas=123 123=312312 x="dasdas asd as as das das das das das" as="adsasdas"
adas=123 123=312312 x="dasdas asd as as = das das das das das" as="adsasdas"
adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'
adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}