import Foundation
let pattern = #"(?:([a-zA-Z0-9]+)=(?:([^\v '"]+)|"(.*?)"|'(.*?)')|([a-zA-Z0-9]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
a=123 344=555
a=1 b=2 c=3
delim=; trst=.... c=3
delim=; trst=".... " c=3
x=12 abc="asdasda"
x12 abc="asdasda"
x13 xddss='asdasda'
x13=213 xddss='asdasda'
adas=123 123=312312 x="dasdas asd as as das das das das das" as="adsasdas"
adas=123 123=312312 x="dasdas asd as as = das das das das das" as="adsasdas"
adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'
adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)