import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|([a-zA-Z0-9]+)=(?|([^\\v '\"]+)|\"(.*?)\"|'(.*?)')|([a-zA-Z0-9]+))";
final String string = "a=123 344=555\n"
+ "a=1 b=2 c=3\n"
+ "delim=; trst=.... c=3\n"
+ "delim=; trst=\".... \" c=3\n"
+ "x=12 abc=\"asdasda\"\n"
+ "x12 abc=\"asdasda\"\n"
+ "x13 xddss='asdasda'\n"
+ "x13=213 xddss='asdasda'\n"
+ "adas=123 123=312312 x=\"dasdas asd as as das das das das das\" as=\"adsasdas\"\n"
+ "adas=123 123=312312 x=\"dasdas asd as as = das das das das das\" as=\"adsasdas\"\n"
+ "adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'\n"
+ "adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}