import re
regex = re.compile(r"(?|([a-zA-Z0-9]+)=(?|([^\v '\"]+)|\"(.*?)\"|'(.*?)')|([a-zA-Z0-9]+))", flags=re.DOTALL)
test_str = ("a=123 344=555\n"
"a=1 b=2 c=3\n"
"delim=; trst=.... c=3\n"
"delim=; trst=\".... \" c=3\n"
"x=12 abc=\"asdasda\"\n"
"x12 abc=\"asdasda\"\n"
"x13 xddss='asdasda'\n"
"x13=213 xddss='asdasda'\n"
"adas=123 123=312312 x=\"dasdas asd as as das das das das das\" as=\"adsasdas\"\n"
"adas=123 123=312312 x=\"dasdas asd as as = das das das das das\" as=\"adsasdas\"\n"
"adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'\n"
"adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")