// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)(?|([a-zA-Z0-9]+)=(?|([^\v '"]+)|"(.*?)"|'(.*?)')|([a-zA-Z0-9]+))"#).unwrap();
let string = "a=123 344=555
a=1 b=2 c=3
delim=; trst=.... c=3
delim=; trst=\".... \" c=3
x=12 abc=\"asdasda\"
x12 abc=\"asdasda\"
x13 xddss='asdasda'
x13=213 xddss='asdasda'
adas=123 123=312312 x=\"dasdas asd as as das das das das das\" as=\"adsasdas\"
adas=123 123=312312 x=\"dasdas asd as as = das das das das das\" as=\"adsasdas\"
adas=123 123=312312 x='dasdas asd as as das das das das das' as='adsasdas'
adas=123 123=312312 x='dasdas asd as as = das das das das das' as='adsasdas'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}