#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[A-Z])(?=.*[a-z])(?=.*\d).{8,}"
Local $sString = "A1213pokl" & @CRLF & _
"bAse730onE" & @CRLF & _
"asasasasasasasaas" & @CRLF & _
"QWERTYqwerty" & @CRLF & _
"123456123456" & @CRLF & _
"QwErTy911poqqqq" & @CRLF & _
".........." & @CRLF & _
"876876987"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")