import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[A-Z])(?=.*[a-z])(?=.*\\d).{8,}";
final String string = "A1213pokl\n"
+ "bAse730onE\n"
+ "asasasasasasasaas\n"
+ "QWERTYqwerty\n"
+ "123456123456\n"
+ "QwErTy911poqqqq\n"
+ "..........\n"
+ "876876987";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}