package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\;(?<myfield>[\d.]+)\\;`)
var str = `Axxtalled=xrxnx xx Client\;12.0.5294\;15.179.00\;3x/x/2xx\;,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}