re = /\\;(?<myfield>[\d.]+)\\;/m
str = 'Axxtalled=xrxnx xx Client\\;12.0.5294\\;15.179.00\\;3x/x/2xx\\;,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end