// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\;(?<myfield>[\d.]+)\\;").unwrap();
let string = "Axxtalled=xrxnx xx Client\\;12.0.5294\\;15.179.00\\;3x/x/2xx\\;,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}