#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((\d{2})\/(\d{2})\/(\d{4})$))|(((\d{1})\/(\d{1})\/(\d{4})$))|(((\d{1})\/(\d{2})\/(\d{4})$))|(((\d{2})\/(\d{2})\/(\d{2})$))" & @CRLF & _
"|(((\d{1})\/(\d{1})\/(\d{2})))" & @CRLF & _
""
Local $sString = "DOB 06/05/2020" & @CRLF & _
"DOB 6/5/2020" & @CRLF & _
"DOB 6/05/2020" & @CRLF & _
"DOB 06/05/20" & @CRLF & _
"DOB 6/5/20" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")