$re = '/(((\d{2})\/(\d{2})\/(\d{4})$))|(((\d{1})\/(\d{1})\/(\d{4})$))|(((\d{1})\/(\d{2})\/(\d{4})$))|(((\d{2})\/(\d{2})\/(\d{2})$))
|(((\d{1})\/(\d{1})\/(\d{2})))
/m';
$str = 'DOB 06/05/2020
DOB 6/5/2020
DOB 6/05/2020
DOB 06/05/20
DOB 6/5/20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);