import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((\\d{2})\\/(\\d{2})\\/(\\d{4})$))|(((\\d{1})\\/(\\d{1})\\/(\\d{4})$))|(((\\d{1})\\/(\\d{2})\\/(\\d{4})$))|(((\\d{2})\\/(\\d{2})\\/(\\d{2})$))\n"
+ "|(((\\d{1})\\/(\\d{1})\\/(\\d{2})))\n";
final String string = "DOB 06/05/2020\n"
+ "DOB 6/5/2020\n"
+ "DOB 6/05/2020\n"
+ "DOB 06/05/20\n"
+ "DOB 6/5/20\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}