import re
regex = re.compile((r"(((\d{2})\/(\d{2})\/(\d{4})$))|(((\d{1})\/(\d{1})\/(\d{4})$))|(((\d{1})\/(\d{2})\/(\d{4})$))|(((\d{2})\/(\d{2})\/(\d{2})$))\n"
r"|(((\d{1})\/(\d{1})\/(\d{2})))\n"), flags=re.MULTILINE)
test_str = ("DOB 06/05/2020\n"
"DOB 6/5/2020\n"
"DOB 6/05/2020\n"
"DOB 06/05/20\n"
"DOB 6/5/20\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")