package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))`)
var str = `0.0.0.0
255.255.255.255
256.129.23.5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}