import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))";
final String string = "0.0.0.0\n"
+ "255.255.255.255\n"
+ "256.129.23.5\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}