#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/scheduling\/groups\/(?:list|get|search).*\.json"
Local $sString = "/scheduling/groups/list.json" & @CRLF & _
"/scheduling/groups/getGroup.json" & @CRLF & _
"/scheduling/groups/searchMember.json" & @CRLF & _
"" & @CRLF & _
"/scheduling/groups/save.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")