$re = '/\/scheduling\/groups\/(?:list|get|search).*\.json/m';
$str = '/scheduling/groups/list.json
/scheduling/groups/getGroup.json
/scheduling/groups/searchMember.json
/scheduling/groups/save.json';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);