using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/scheduling\/groups\/(?:list|get|search).*\.json";
string input = @"/scheduling/groups/list.json
/scheduling/groups/getGroup.json
/scheduling/groups/searchMember.json
/scheduling/groups/save.json";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}