import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/scheduling\\/groups\\/(?:list|get|search).*\\.json";
final String string = "/scheduling/groups/list.json\n"
+ "/scheduling/groups/getGroup.json\n"
+ "/scheduling/groups/searchMember.json\n\n"
+ "/scheduling/groups/save.json";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}