using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)\s(\d)";
string substitution = @"$1 $2";
string input = @"367,881 1,092,781 17,819 220 89,905 194,627 342 1,763,575";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}