import Foundation
let pattern = #"(\d)\s(\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"367,881 1,092,781 17,819 220 89,905 194,627 342 1,763,575"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}