// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d)\s(\d)").unwrap();
let string = "367,881 1,092,781 17,819 220 89,905 194,627 342 1,763,575";
let substitution = "$1 $2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}