#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\s"
Local $sString = "" & @CRLF & _
"BTC address to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX" & @CRLF & _
"[case-sensitive copy and paste it]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")