re = /\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\s/i
str = '
BTC address to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX
[case-sensitive copy and paste it]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end