const regex = /\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\s/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\\s', 'gi')
const str = `
BTC address to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX
[case-sensitive copy and paste it]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}