import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\\s";
final String string = "\n"
+ "BTC address to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX\n"
+ "[case-sensitive copy and paste it]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}