use strict;
my $str = 'Lorem dolor sit amet, consectetur adipisicing elit,
sed do ipsum eiusmod tempor incididunt ut labore et dolore magna aliqua.';
my $regex = qr/^(?si)(?!.*\blorem\b.*\bipsum\b|\bipsum\b.*\blorem\b.*$).*$/p;
my $subst = '$2/$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";